Chroma Battery Issue

Discussion in 'Help' started by Ben M, Jan 4, 2018.

  1. Ben M

    Ben M Member

    Dec 18, 2017
    52
    2
    8
    Male
    So I was about to charge my 7200mah Chroma battery and I noticed that one of the cells has a lower voltage than the other two. I also noticed that the total voltage remaining is 10.8V, well enough to keep flying. I'm kind of thinking that it is the heat during flight that makes it have reduced voltage readings to the ST-10, but the varying voltages is concerning.
     

    Attached Files:

  2. Lawrence

    Lawrence Well-Known Member

    Jan 19, 2016
    992
    271
    63
    Male
    I'm really not as techie as you may think! I really never pay much attention to voltage, I fly down to 10.8 then I head for home but I check cell resistance after each charge. If a cell has a cell that has resistance over 10 I don't use that battery anymore. I will charge and discharge it a few times and if the cell still reads over 10 that battery is put to rest. I use a Hitec X2 for charging and checking cell resistance.
     
  3. Ben M

    Ben M Member

    Dec 18, 2017
    52
    2
    8
    Male
    Yeah, after I did some research I learned that it was not really a big deal. I fly my battery until 10.5 or 10.4, but I don't think I'm hurting it as I know 3.5V per cell is not damaging it. What amperage do you charge your battery at, and how long does it take? My 7200mah one takes like an hour and a half at 5amps.
     
  4. Lawrence

    Lawrence Well-Known Member

    Jan 19, 2016
    992
    271
    63
    Male
    I use 6300 mah batteries and I charge 2 at a time. It takes about 45 minutes.
     
  5. Ben M

    Ben M Member

    Dec 18, 2017
    52
    2
    8
    Male
    What the heck... How does my single 7200mah at 6amps take an hour and a half. What charger do you have?

    Also, is a sudden voltage drop from like 12.4 to 11.8 a sign of a bad battery?
     
  6. Lawrence

    Lawrence Well-Known Member

    Jan 19, 2016
    992
    271
    63
    Male
    Mine drops pretty quickly to below 12. I've never used a 7300mah battery so I don't know what is normal. I use a Hitec X2. Nice little charger.
    upload_2018-1-5_18-14-57.jpeg
     
  7. Ben M

    Ben M Member

    Dec 18, 2017
    52
    2
    8
    Male
    Guess it might just be the Chroma's voltage reader. I'm only getting about 22 minutes of flight time now, compared to the 27-30 that I was getting. What amperage do you charge your batteries at?
     
  8. Lawrence

    Lawrence Well-Known Member

    Jan 19, 2016
    992
    271
    63
    Male
    6.3
     
  9. Ben M

    Ben M Member

    Dec 18, 2017
    52
    2
    8
    Male
    I'm charging mine at 7amps and it still takes over an hour. Probably because it has to charge 6000-6500mah.
     
  10. RonK95

    RonK95 Active Member

    Nov 16, 2015
    170
    45
    28
    Male
    Coder
    Ohio, USA
    Hi Lawrence: When you say you check the cell resistance, do you mean with an OHM meter? and if it's over 10K (?) Ohms, you retire the battery?

    Thanks
    RonK95
     
  11. Lawrence

    Lawrence Well-Known Member

    Jan 19, 2016
    992
    271
    63
    Male
    My charger (hitec x2) has a feature of checking cell resistance and yes, anything over 10 gets put on steady grip duty.
     
  12. RonK95

    RonK95 Active Member

    Nov 16, 2015
    170
    45
    28
    Male
    Coder
    Ohio, USA
    Thanks Lawrence. I don't think my charger has that feature, but I do own any number of ohn/volt meters.

    RonK95

    Oh, and BTW, do you know of any reliable source for Chroma batteries? They are getting scarce (Horizon Hobby has them listed as unavailable) and some of the vendors I've seen on line are asking ridiculous prices.
     
  13. Lawrence

    Lawrence Well-Known Member

    Jan 19, 2016
    992
    271
    63
    Male
    Oh boy, I haven't bought a battery for a long long time. I got my extra batteries from my local dealer. I better pop in and see if he has any.
     
  14. RonK95

    RonK95 Active Member

    Nov 16, 2015
    170
    45
    28
    Male
    Coder
    Ohio, USA
    Yeh ... good idea. This is the trouble with "proprietary" battery packs ... once the model falls "out of favor" there's no money in producing new batteries. I'm looking into breaking one of my dead batts and buying "standard" LiPo's and see if I can rig some kind of "cradle" to hold them in the Chroma battery shell. Shouldn't be too difficult, I would think.

    Thanks for the information.
    RonK95
     
  15. Penny McLaurin

    Penny McLaurin New Member

    Mar 19, 2019
    2
    0
    1
    Male
  16. Penny McLaurin

    Penny McLaurin New Member

    Mar 19, 2019
    2
    0
    1
    Male
    My Blade Chroma takes off, gets about 15 or 20 ft. lights turn red and comes back down to land. Could that be my battery???
     
  17. WTFDproject

    WTFDproject Well-Known Member
    Staff Member

    Oct 3, 2018
    1,019
    159
    63
    Male
    Retired Power Plant
    North Carolina Piedmont
    Yes. It sounds like the battery is bad. I assume you are fully charging it between flights, and it just does not have any storage capacity left. The PDF below is the LED quick reference card for the Blade Chroma.
     

    Attached Files:

Loading...

Share This Page