Q500 4K ESC Issue - Restart Required

Discussion in 'Q500/Q500+/Q500 4K/Typhoon G' started by Josh Arnold, Jan 1, 2017.

  1. Jos

    Josh Arnold New Member

    Joined:
    Jan 1, 2017
    Messages:
    2
    Likes Received:
    0
    Hi Guys,

    I am a new owner of my Q500 4k. I took it out for her maiden voyage with no problems. Then I updated the firmware and took my Typhoon outside when i started it up it cartwheeled and broke 3 propellers. On closer inspection it appears that motor 4 is spinning clockwise when the motor indicates it should be counter clockwise. I have tried assigning the ESC ID assignment and when i get to Rotor 4 it tells me to restart my Drone. When I reboot it the rotor appears to be spinning the wrong way. I don't know what to do, I don't want to take it outside and break another set of props or even the camera. Any help would be appreciated because i have no idea.

    Thanks
     

    Attached Files:

  2. Jagerbomb52

    Jagerbomb52 Moderator Staff Member

    Joined:
    Jun 3, 2015
    Messages:
    4,763
    Likes Received:
    1,759
    Location:
    Canada
    Do a reinstall of the firmware. After that hook it back up to the GUI and reassign everything again. Hopefully that will fix it.
     
  3. Jos

    Josh Arnold New Member

    Joined:
    Jan 1, 2017
    Messages:
    2
    Likes Received:
    0
    Thank you for your prompt reply the motor started smoking when i started it up so i will be returning it first thing tomorrow.
     
  4. Jagerbomb52

    Jagerbomb52 Moderator Staff Member

    Joined:
    Jun 3, 2015
    Messages:
    4,763
    Likes Received:
    1,759
    Location:
    Canada
    LOL
    Good call :)
     
  5. Tank

    Tank Member

    Joined:
    Aug 9, 2016
    Messages:
    73
    Likes Received:
    8
    Send it back to Yuneec.
     
Loading...

Share This Page

Loading...