Q500 4K Gimbal won't pan up and down, but does stay level

Discussion in 'Q500/Q500+/Q500 4K/Typhoon G' started by vinsanity, Jun 12, 2018.

  1. vinsanity

    vinsanity New Member

    Jun 12, 2018
    5
    0
    1
    Male
    I just got a q500 4K used, and one thing I didn't fully test was the gimbal and naturally I'm having a problem with it. It always points straight at the horizon. (While the props are off) I can tilt the front drone and the gimbal properly levels out. So it's mostly working, however, when I adjust the slider on the left side of the controller, the controller beeps, but the gimbal does nothing. When I put the ST10+ in hardware monitor mode and slide it up and down K1 ranges from 1-197.

    I also tried putting it in the steady grip, and the thumb wheel does nothing, though I didn't pair it with my phone or anything. Firmware on the ST10+ & drone are up to date. About to check the gimbal.

    Thoughts?
     
  2. vinsanity

    vinsanity New Member

    Jun 12, 2018
    5
    0
    1
    Male
    Also there is a suspiciously not connected to anything wire out the back... :mad:
     

    Attached Files:

    • CGO3.jpg
      CGO3.jpg
      File size:
      297.7 KB
      Views:
      56
  3. Jonathan Enssle

    Oct 23, 2017
    116
    11
    18
    Male
    Student
    Boulder Colorado
    That wire is your problem. I ripped those three gimbal wires off, soldered two back on, and the same thing happened. However DON'T SOLDER THEM BACK! Unless you have much more experience than I do, which wouldn't be difficult. Those three wires control the camera and gimbal, they are the wires that come from the contact at the top of the camera. Up to you, but contact whoever sold you the quad and let them know! Here is a link, to a replacement connector.
    https://www.bhphotovideo.com/c/prod...4IQ80dw_1jua19kNGTI7NrD4gbKVY_AMaAoD0EALw_wcB
    Hope that helps!
     
  4. vinsanity

    vinsanity New Member

    Jun 12, 2018
    5
    0
    1
    Male
    Thanks. You sure that's the right piece? Is the circuit board in the back side of the black piece on the left in the product picture?
     

    Attached Files:

  5. vinsanity

    vinsanity New Member

    Jun 12, 2018
    5
    0
    1
    Male
    I think I really need one of these: https://www.bhphotovideo.com/c/product/1223054-REG/yuneec_yuncgo3105svc_main_board_of_cgo3.html. Sadly it looks like the pad pulled off the board so I can't just solder it back down. Also unfortunately, it looks like the board does not come with the pin contacts on the top of the gimbal, I have no choice but to solder my existing 3 wires to the new board.

    I'm not sure where the cable Jonathan linked to is. Maybe it's a different model because I don't see anything like it. I have a whole bunch of things plugged into this board, then 3 wires soldered directly to the board that got to 3 pins on the top of the Gimbal. No plugs involved.
     
  6. Jonathan Enssle

    Oct 23, 2017
    116
    11
    18
    Male
    Student
    Boulder Colorado
    The three pin contacts are in that white rectangular on the left side of the board in your picture. I do not think you need a new board. That cable replaces the 3 wires soldered directly to the board that go to 3 pins on the top of the Gimbal. Just so you know, a new board won't do you any good, as it needs to be calibrated to the camera by a Yuneec dealer/repair center.
     
  7. Bruce

    Bruce Active Member

    Aug 25, 2016
    155
    52
    28
    Male
    I have a Q500 4K and it should be connected by the contacts under the track, I have never hooked up a wire to the plug in terminals and it works fine, the gimbal seems to be working, have you checked to switch on the controller , that is what moves the camera up and down
     
  8. vinsanity

    vinsanity New Member

    Jun 12, 2018
    5
    0
    1
    Male
    Jonathan was right. It appears there are 2 ways the gimbal can connect to the drone: via a 3 pin contact connector on the top of the gimbal, or a separate wire that plugs into the back of the board and into the bottom of the drone about an inch or so behind the gimbal mount.

    Mine used the 3 pin contact connector, but I see other pictures/videos of Q500 4K with the wire. I plugged the cable in and all is good. Kinda unusual to have this redundancy, makes me think they tried to change designs and have a lot of parts that support both.

    Thanks guys.
     
  9. Jonathan Enssle

    Oct 23, 2017
    116
    11
    18
    Male
    Student
    Boulder Colorado
    Great! Glad to see everything is good.
     
Loading...

Share This Page