H520 Fly away.... Help identifying the issue needed!

Discussion in 'H520 Hexacopter' started by Swigmofa, Jul 1, 2020.

  1. Swigmofa

    Swigmofa New Member

    Apr 23, 2019
    First, Where has Yuneec USA gone? No phone numbers, website has no ability to setup a call....

    Yesterday while flying a test flight (I was trying to test the battery switch when flying a way point flight plan) I lost control of the drone.
    I am looking for some help identifying what happened. This drone was a replacement last year (flying missions that required battery changes failed to work at all - controller and drone would not be able to continue at all after the battery change) that I have hardly used.

    The first flight went well, battery depleted and the drone returned to take off point.
    Switched the battery and tried to continue the mission but the mission restarted so I landed and selected the way point I believed the drone reached with the first battery.
    I manually took of (I think, might have been the previous take off) and then selected to continue the mission, very shortly after the drone started flying very erratically. I tried repeatedly to cancel the mission and take control, the controller was repeatedly saying " Returned control to pilot" but i never regained control.
    Once the drone crashed, I found that one of the motors was still turning even though the drone was on it's side.

    This is the flight log from the airframe. (the flight log from the controller was corrupt and so far i haven't been able to open it).

    I have a mission to fly with this drone on Friday so i have to get some replacement parts fast (an arm is the main part) and then some testing providing someone can give guidance on why this happened.
  2. h-elsner

    h-elsner Active Member

    The only thing I see is a GPS lost at 4:28 and 5-Rotor Mode at 6:02 (don't know what that mean). I think the crash was already around 5:05.
    The charts are not good readable for problem analysis. Those are made for PID tuning, airframe stability and so on.
    Can you please provide the TLOG file from controller as raw data?

    br HE
  3. Swigmofa

    Swigmofa New Member

    Apr 23, 2019
    Turns out the tlog file I thought was for this flight that was unreadable was for another flight.

    I have attached the tlog file (with txt extension to get it to upload)
  4. Swigmofa

    Swigmofa New Member

    Apr 23, 2019
    There are a number of logs stating changes to do with rotor mode's and various "motor stalling" but they all started at 5:06.
    5.06 is where the aircraft landed and rolled

    Using UAV Toolkit i was able to see what the controller thought the aircraft was doing but if you compare that to the file from the aircraft it is completely different from the point it lost control.
  5. h-elsner

    h-elsner Active Member

    The tlog-file from controller contais a mass of data. There are 3 flights in:
    #1 A long flight with the first battery. I will ignore those datasets.
    #2 First flight with the second battery.
    #3 Second flight with the second battery.

    The "Battery used" values are counted over both batteries. Strange, flight controller did not realized that battery was changed (battery remains: 89%, which is OK from voltage; 6514mAh used --> this would mean the battery has 59000mAh - I would like to have such a battery ;-)). I don't know if this is normal.

    Let's have a look on the flight #3:
    434120 00:03:26 INFO: 'Armed by RC.'
    434132 00:03:26 INFO: '[logger] file: /fs/microsd/log/2020-07-01/00_37_3'
    434663 00:03:29 INFO: 'Takeoff detected'

    446885 00:04:28 CRITICAL: 'Failsafe enabled: no global position'
    446893 00:04:28 INFO: 'Failsafe mode on.'

    follwed by a lot of messages for 10s between:
    450511 00:04:47 CRITICAL: 'Returned control to pilot, paused mission.'
    452351 00:04:57 CRITICAL: 'Returned control to pilot, paused mission.'
    Recording ends at 00:05:02.61, some time before it will get interesting, sad.

    The raw data from some important the recorded MAVlink messages (as zip file).
    And this is the flight track:

    Is it the one you described as flight as last flight?

    My guess is that the problem starts with compass errors (but there are no messages regarding electromagnetic field!).
    The mag values start to swing and then GPS was lost:
    GPS support was lost, you have to fly manually. I don't know why the message "Returned control to pilot, paused mission" was raised so often. Maybe for each waypoint? How many did you plan for the last part of the flight?

    Failsave is visible in next chart. It starts to descent and did not respond to the throttle stick any more:

    There is lot of movement in 3 axis without coincidence with stick input:

    br HE

    Attached Files:

  6. Swigmofa

    Swigmofa New Member

    Apr 23, 2019
    Thank you for reviewing this data.

    You are correct, the file contains data for 3 flights, the last being the one with the loss of control.

    I distinctly remember looking at the controller once the new battery was in and the drone started up. For a short period of time it still showed the 18% or so of battery left but then went to 100% so i'm not sure why this was not recorded correctly but might explain why i wasn't able to continue the mission correctly.

    The critical 'Failsafe enabled' i believe was a few seconds after i had issued the command to continue the planned mission from the point i had selected.

    At around 5:02 I think I forced the Datapilot to close in the hope it would allow me to take control but 4 seconds later the drone was on the ground.

    "Is it the one you described as flight as last flight?"
    The mapping is kind of close to the actual flight.

    I do not know if the GPS signal was lost because of the angle of the drone as it really was flying very erratically - steep banks to the point at one stage it looked like it had flipped.

    I have since flown the drone in a large open space, first with a rope on it so there was no way it was going far but after a while of seeing no issue I flew without the rope a little further - about 300ft away. All of a sudden the drone reported loss of controller signal and was returning to home. I looked at the controller and everything looked good, I was still pointing the boosted antenna in the direction of the drone as it returned to me next to the take off location but the control never returned even once the drone had landed next to me. I tried resetting everything and the connection returned. I swapped out the ST16S for another that I have and was able to fly without any issues at all.
    So currently my conclusion is that the combination of trying to return to the planned mission, some sort of loss of the GPS signal and then me trying to take control with a controller that is not functioning correctly resulted in the aircraft going through a loop of trying to return the control but failing so trying to run the mission again but with no GPS signal so the aircraft started trying to just land where it was while flicking through these states repeatedly. There was a fair amount of wind, around 6 to 8mph with some gusts which just added to the problem.

    Any suggestions on what to do with the ST16S? Is there a way to test it or for me to get it repaired?

Share This Page