Typhoon G How to Change

Discussion in 'Modifications' started by Johnny JAckson, Sep 28, 2017.

  1. Johnny JAckson

    Johnny JAckson New Member

    Sep 28, 2017
    3
    0
    1
    Male
    I am wanting to convert my Q500 4K to a Q500 G so I can attach a FLIR Duo-R. I did the firmware updated on both the remote and aircraft to Q500 G and installed the gimbal and MK 58 binded both but only get a blue screen on the remote. No imaging from the camera. Not sure what is wrong.
     
  2. Jagerbomb52

    Jagerbomb52 Guest

    Sounds like the AV out from the camera is not working.
     
  3. Jagerbomb52

    Jagerbomb52 Guest

    Is there a setting on the camera to turn AV on and off maybe?
     
  4. Jagerbomb52

    Jagerbomb52 Guest

    Also try deleting the model and create a new model. Have the camera on when binding and it might see it then.

    Turn Everything Off Bird and TX

    Turn on the ST10+ but not the bird

    After it initializes select Model. Select it at the bottom right of screen.

    Touch and Hold the model. Menu appears. Touch & DELETE.

    Now turn off ST10+

    Turn on the Bird. After it is on, Tilt forward from the back end 45 degrees two times to enter Bind Mode. Back light will start flashing Orange.

    Turn on ST10+ Select Flight Settings,at this time it will ask you to go to model select and create a new model. Once you have giving it a name click save and then Select Bind. Bind the Model and Bind the Camera

    Tap Return Button at bottom of ST10+ a few times to get back to main screen. You should now see the camera come up on display.
     
  5. Johnny JAckson

    Johnny JAckson New Member

    Sep 28, 2017
    3
    0
    1
    Male
    I removed the camera for my Solo and it was working fine it is a HERO 3 Black.
     
  6. Jagerbomb52

    Jagerbomb52 Guest

    So are you saying you don't have the flir yet? If no camera is connected all you will get is a blue screen.
     
  7. Johnny JAckson

    Johnny JAckson New Member

    Sep 28, 2017
    3
    0
    1
    Male
    I do have the FLIR Duo-R camera but when I was getting the blue screen I decided to put in my GOPRO 3 to check and see if it was because I was using the DUO.
     
Loading...

Share This Page