Maintance on st16+.

Discussion in 'Typhoon H Discussion' started by boomcaddy, Jan 5, 2020.

  1. boomcaddy

    boomcaddy New Member

    Mar 1, 2019
    9
    9
    3
    Hello guys,
    I Just got a story to tell so IT might help somebody.
    My h would spin around without any warming and i could allways het it back by steering the other wat but it got harder to control it every time i flew.i found out that it was not the drones problem but the st16.
    The left joystick would drift.so i took IT apart and cleaned en greased IT.
    So now i could see on the st16 that the controls where all working fine now.yes mission succes i thought.
    So a couple of days later i went out and tried to fly the h.it did everything but fly,the motors on button Just didn't work.i Saw on the st16 that the button did work but the damn thing Just wouldnt work.
    So angry and frustrated i took it back home and started the research.
    I figgered out that it must had something to do with binding orso because i took the battery out of the st16 when i openend it up.the strange thing was i could control the camera,but ok.
    I did a factory reset on the st16 binded the 2 together.did a compas and camera calibration and then i could start up the motors but that wasnt the end of it.
    The cgo3 camera now suddenly would only look down and that would drift to the left....very weird.
    I found out on the internet that there was a hidden menu om the st16 to calibrate the switches.there is a very good video on YouTube of that.the important thing about that is(i didn't the first 2 Times) that you center the left and right sliders( the ones on the back/side).

    Now my h works great again but it took alot of patience.

    I hope this story Will help some one in the future.

    Im sorry if my english is not that great but i tried.[​IMG][​IMG]

    Verstuurd vanaf mijn ONEPLUS A5010 met Tapatalk
     
    Codestar7 and WTFDproject like this.
  2. WTFDproject

    WTFDproject Active Member
    Staff Member

    Oct 3, 2018
    815
    108
    43
    Male
    Retired Power Plant
    North Carolina Piedmont
    @boomcaddy
    Your post is far more important than you might think. Almost ALL of the you tube videos out there are WRONG, and you found out the hard way. A lot of effort was spent trying to remove the bad videos, but to no avail.
    There are only two videos on YouTube that are done correctly for the ST10, and only one done correctly for the ST16. But there is no way to alert folks other than posts like yours.

    Using the wrong guidance WILL MESS UP YOUR CONTROLLER at best.

    The correct written guidance, and links to the correct YouTube videos are contained in "https://yuneec-forum.com/threads/way-to-fix-drones-project.10229/". The guidance (Attachment 25) uses an ST10 as it's basis, but the essential process is the same for the ST16. There is also a video link in the document table of contents specifically for the ST16.
     
    boomcaddy likes this.
  3. boomcaddy

    boomcaddy New Member

    Mar 1, 2019
    9
    9
    3
    I used An other video ,this is the one



    Verstuurd vanaf mijn ONEPLUS A5010 met Tapatalk
     
  4. WTFDproject

    WTFDproject Active Member
    Staff Member

    Oct 3, 2018
    815
    108
    43
    Male
    Retired Power Plant
    North Carolina Piedmont
    Wow. That one is great. I had not looked for new videos in a while. That is the ST16 version of the ST10 calibration made by the same group (Yuneec Europe) that produced one of the two ST10 videos already recommended by the document. I will add a link to this one also. Good Job.
     
    boomcaddy likes this.

Share This Page