Solved My GPS won't enable!

Discussion in 'Help' started by als88, May 9, 2015.

  1. als88

    als88 New Member

    May 9, 2015
    9
    2
    3
    Male
    Why did you delete my question and my profile? This is the Yuneec help forum? I need help.

    My GPS will not enable. I have tried the manual way and it did not work. I have tried placing it outside and starting it out there. That didn't work.

    I never turned off the GPS. What would make this happen and how do I get it back on?

    Any other ideas? I really want to be out flying my Q.

    Thanks.
     
  2. midego

    midego Administrator
    Staff Member

    Feb 7, 2015
    1,673
    287
    83
    Male
    The Netherlands
    As stated on top of the forum there were some minor issues with the old software, glad to have you back on board:

     
  3. als88

    als88 New Member

    May 9, 2015
    9
    2
    3
    Male
    Thanks.

    Sorry, I didn't read that.

    I have been up all night trying to figure this out. I could really use the help. Tomorrow is my last day of freedom before I have to go back to work. I really want to fly! :(
     
  4. midego

    midego Administrator
    Staff Member

    Feb 7, 2015
    1,673
    287
    83
    Male
    The Netherlands
    Did you already try to manually re-enable the GPSwith the tutorial I've send you?
     
  5. als88

    als88 New Member

    May 9, 2015
    9
    2
    3
    Male
    #5 als88, May 9, 2015
    Last edited: May 9, 2015
    Yes.

    Right TX knob is at full rabbit.
    Right stick, held right.
    Flip switch from Smart to Home 4 times.

    I hear the beep at the end. Nothing changes. I tried it several times. Inside and outside.
     
  6. midego

    midego Administrator
    Staff Member

    Feb 7, 2015
    1,673
    287
    83
    Male
    The Netherlands
    Can you make a photo of your controller so we know exactly what you see.
     
  7. als88

    als88 New Member

    May 9, 2015
    9
    2
    3
    Male
    20150509_104108.jpg
     
  8. midego

    midego Administrator
    Staff Member

    Feb 7, 2015
    1,673
    287
    83
    Male
    The Netherlands
    Are you sure you did it this way, and be sure to swith the flight toggle from Smart to Home and Home to Smart 4 times, not all the way down to RTH.

    Step 1) While the ST10 and Q500 are powered on and linked (and the
    motors are NOT running), move the Proportional Control Rate Slider on the
    right side of the ST10 to the uppermost (rabbit) position.

    Step 2) Move the right-hand stick all the way to the right and hold it there
    until step 3 is completed.

    Step 3) Move the Flight Mode Selection Switch from Smart to Home and
    Home to Smart
    mode 4 times in 3 seconds.
    When GPS has been disabled successfully the Q500 will emit an audible
    indication and the GPS status on the ST10 screen will show ‘Disabled’.
    Also, the Main LED Status Indicator will flash purple and the Below Motor
    LED Status Indicators will flash three (3) times per second then will stay off
    for one (1) second
     
  9. Wnuk

    Wnuk New Member

    May 9, 2015
    13
    3
    3
    Male
    I believe in order for the GPS "enabled" to appear you must have the motors started.
    Also, are you indoors when you took that pic? That can be a hindrance.
     
  10. als88

    als88 New Member

    May 9, 2015
    9
    2
    3
    Male
    Thank you Midego and Wnuk. Your help is really appreciated!

    The problem has been solved. :)

    I went outside, turned on the TX, then the Q. Wnuk was right. The motors have to be on before GPS enables. I feel really stupid right now. :rolleyes:

    I do not know how or why I never noticed that. Anyway, it works and I'm flying again!

    So happy! :cool::D:)

    Thank you both.
     
  11. midego

    midego Administrator
    Staff Member

    Feb 7, 2015
    1,673
    287
    83
    Male
    The Netherlands
    Good to hear that everything works, that is what we are here for.

    I didn't know that the motors need to be on to enable or disable the GPS.
     
  12. Wnuk

    Wnuk New Member

    May 9, 2015
    13
    3
    3
    Male
    midego- I noticed this before so that's why I suggested it. Same for the "mode" display, the motors need to be running to show if you are in smart or angle mode.

    And I believe (may be wrong) you need to have 10 satellites for GPS to enable.

    Glad we could help Als88.
     
  13. als88

    als88 New Member

    May 9, 2015
    9
    2
    3
    Male
    Thanks again Midego.

    Can you add, (Problem Solved) to the title.

    I was surprised to because the manual say's, "make sure the motors are off."
     
  14. midego

    midego Administrator
    Staff Member

    Feb 7, 2015
    1,673
    287
    83
    Male
    The Netherlands
    Done :)
     
  15. als88

    als88 New Member

    May 9, 2015
    9
    2
    3
    Male
    Thanks again to you to Wnuk.

    I did not notice how many satellites were connected. I'm on my out the door to go fly. I'll report back about the satellites in the morning or maybe later this evening.
     
    midego likes this.
  16. als88

    als88 New Member

    May 9, 2015
    9
    2
    3
    Male
    Awesome. :cool:
     
    midego likes this.
  17. midego

    midego Administrator
    Staff Member

    Feb 7, 2015
    1,673
    287
    83
    Male
    The Netherlands
    Now you go out and fly and let us know how it was. Maiden flight?
     
  18. als88

    als88 New Member

    May 9, 2015
    9
    2
    3
    Male
    I love my Q. The bird is rock solid. Just got home again after about an hour of flying around the park.

    I haven't had much time to edit any videos or pictures. I'm off on Wednesday so I will edit and upload them soon.

    Still not sure about the 10 satellites. The GPS is working and is rock solid. It was kind of windy and the Q barely moved.

    Thanks again for the help.
     
  19. midego

    midego Administrator
    Staff Member

    Feb 7, 2015
    1,673
    287
    83
    Male
    The Netherlands
  20. hansg

    hansg Member

    Motors don't have to be started to get GPS enabled! You need at least a steady GPS lock, which means you need to receive quite some satellites, but I never start the engines before everything is enabled, including GPS.
     
Loading...

Share This Page