No model name on Bind menu

Discussion in 'Blade Chroma Series' started by famo, Dec 31, 2018.

  1. WTFDproject

    WTFDproject Active Member
    Staff Member

    Oct 3, 2018
    897
    132
    43
    Male
    Retired Power Plant
    North Carolina Piedmont
    These are the wire guard, and the receiver connector: The GRAY wire is the wire that carries telemetry from the main board to the receiver to be sent to the controller.

    2-Chroma Wire Guard.jpg

    3-Chroma Reciever Connector.jpg






    The following drawing was added 2019/01/02 for additional information:
    1- Chroma Receiver Connections.jpg
     
  2. famo

    famo New Member

    Dec 31, 2018
    10
    1
    3
    #22 famo, Jan 1, 2019
    Last edited: Jan 2, 2019
    Hımmm... So I will remove the wire guard and unplug that connector and reconnect it.

    That sounds reasonable.

    I'll give it a try.
     
  3. WTFDproject

    WTFDproject Active Member
    Staff Member

    Oct 3, 2018
    897
    132
    43
    Male
    Retired Power Plant
    North Carolina Piedmont
    [QUOTE="I'll give it a try.[/QUOTE]
    And if that does not help, look closely at the path of the gray wire, all the way from the receiver to the main board, looking for damage to the wire, bad solder joint, bad pin connection, etc. If you have a circuit tester, it could show you have a good connection all the way.
     
  4. famo

    famo New Member

    Dec 31, 2018
    10
    1
    3
    Guess what happened?
    I brought the drone to work, to analyze it in the office. Than I realized I don't have the torque screwdriver to remove the wire guard. I tried some phillips screwdriver but hopelessly I left it to home. Than I figured out that wire guard is a very elastic type of plastic fence. I applied some pressure on it, pushed some sockets as far as my finger reaches and... bingo! Telemetry is back.

    Now I am waiting for lunch to test it on the backyard. Gear icon is back. I will attach GoPro and perform a compass calibration first. Than after acquiring GPS signal I will try a short flight.
     
    WTFDproject likes this.
  5. WTFDproject

    WTFDproject Active Member
    Staff Member

    Oct 3, 2018
    897
    132
    43
    Male
    Retired Power Plant
    North Carolina Piedmont
    [QUOTE=" I applied some pressure on it, pushed some sockets as far as my finger reaches and... bingo! Telemetry is back..[/QUOTE]

    This is great news. Even if you have to do it again when you get home, it shows you have the problem identified. I have been on a short trip since last evening. It is almost 5AM local time, and I'm about to get some sleep. Please let me know if your test flight is good. I'll see it in a few hours.

    Thank you very much for letting me know it's working,
    Tom Baumgardner
     
  6. WTFDproject

    WTFDproject Active Member
    Staff Member

    Oct 3, 2018
    897
    132
    43
    Male
    Retired Power Plant
    North Carolina Piedmont
    [QUOTE="Now I am waiting for lunch to test it on the backyard.[/QUOTE]

    @famo,
    Please do not make any further flights before fully ensuring the connector is clean and properly seated. The YELLOW wire beside the gray one is the control of your aircraft. You have already determined the connector to be questionable. If you loose the yellow wire while in flight, you may loose your drone.
     
  7. GupTep

    GupTep New Member

    May 12, 2019
    2
    1
    3
    Someone could indicate the exact sequence to activate the service menu for TVs of the k series . Thank You so much . Yours sincerely
     
Loading...

Share This Page