Q500+ Q500 has gotten progressively slower.

Discussion in 'Q500/Q500+/Q500 4K/Typhoon G' started by YorkState, Oct 27, 2018.

  1. YorkState

    YorkState New Member

    Oct 6, 2018
    13
    1
    1
    I remember how my Q500 used to fly when I first got it, but I've noticed that over the past few months it has become progressively slower, does anyone know why this may be?
     
  2. HarveyH54

    HarveyH54 Active Member

    I don't know the answer, my 4k was FBR after about 6 months, fatal crash. Parts to rebuild would cost more than half, replacing. Bought a Q500+, which has worked for about a year now, but don't abuse it like I did the 4k. On my 4k though, I did notice one motor got a lot warmer than the others, not really hot. I check my blades every flight, before putting in the fresh battery. Didn't seem to effect flight, motor spun freely by hand, didn't feel any rough spots.

    Do you calibrate? I don't very often, sometimes when I travel though. Might be slow, because it's working harder to keep level, or correctly oriented. Sensors are saying one thing, gravity saying something else. I do most of my flying in turtle mode, as I'm recording the entire flight. Might speed it up for the return home, but not that often. I try to get it back on the ground before the low battery alarm goes off.

    On my 4k, the original battery got a little puffy (noticeable), after only 2 months of use. Didn't notice any difference in speed or other performance, just shorter flights, before the low-battery alarm. Got down to 10-12 minutes, and I stopped using it, ordered new batteries. The 4k crashed, apparently from a bad battery connection. I never got around to opening it up to take a closer look, but it either broke or melted, on post (positive side) is pushed all the way back, and out of the plastic holder. Shouldn't effect speed though.
     
  3. WTFDproject

    WTFDproject Active Member
    Staff Member

    Oct 3, 2018
    962
    146
    43
    Male
    Retired Power Plant
    North Carolina Piedmont
    Just a guess, but I wonder if maybe it's the controller, not the Q500. The "rabbit / turtle" (K2) control on the side of the controller may be going bad. Is there any way you could try another controller?
     
  4. Bruce

    Bruce Active Member

    Aug 25, 2016
    221
    72
    28
    Male
    I have the flight sim from Yuneec and find it works great for testing the controller too, it does everything just the same on the screen as it would on the real drone and if something is wrong with the controlor, it will show up on the sim.......I use it when I make repair to the controlor to test it and make sure everything is OK befor using it on the expensive drone...
     
  5. nrrtrains

    nrrtrains Well-Known Member

    Jul 27, 2015
    1,245
    262
    83
    Male
    Staten Island New York USA
    the "rabbit / turtle" (K2) control i bleive is a adjustable pot ,if you just move it back and forth a number of times if it has a little resistance in it it should clean it up .if not you can open the ST-10 and spray contact cleaner in the pot to clean it up .
     
Loading...

Share This Page