ST10+ Controller loses Video Connection

Discussion in 'ST10(+) Controller' started by Johnny Pyke, May 18, 2018.

  1. Johnny Pyke

    Johnny Pyke New Member

    May 18, 2018
    1
    0
    1
    Male
    Toronto, Ontario, Canada
    Hi All, I have just learned of this Forum so I apologize if this question has been answered already

    I have a Yuneec Typhoon G, that I love!
    What I don't love is the fact that I lose Video Connection when it is only 10 - 20 feet away from the ST10+ Controller.
    I did buy this drone used, and the seller did inform me that the Photo/Video Record buttons did not work on the ST10+ Controller with GoPro cameras. (Thanks GoPro!)

    Could someone please point me in the right direction to correct this problem.

    Below are my specs:
    Yuneec Typhoon G
    Model# ST10+
    Android Version: 4.0.3
    Kernel Version: 3.0.8
    Build Number: ST10+v02b27c
    Hardware version: p1.4

    And I have tried using GoPro Hero 3+ Black and GoPro Hero 4 Black.

    Thank You!
     
  2. h-elsner

    h-elsner Active Member

    My first idea is a broken pin at the antenna connector between MK58 and Antenna. Look inside the connector (all powered off!).
    Or the antenna itself is broken.
    There is another trap: Whe transmitter was powered on without antenna connected then the HF part of the MK58 may be burnt.

    Can you try another MK58? Maybe the dealer can help with this. Just to see on which side the problem is, ST10 or MK58 video transmitter.

    br HE
     
Loading...

Share This Page