Trying to figure out what happened

Discussion in 'Blade Chroma Series' started by E_Bro, Feb 1, 2018.

  1. E_Bro

    E_Bro New Member

    Aug 1, 2016
    19
    3
    3
    I was flying the other day, in the afternoon. In the middle of the flight I got a message on the ST-10+ saying GPS was lost and I needed to fly without GPS. I believe the LEDs under the motors turned white, but I had some adrenaline going and I'm not sure. I was in angle mode and I believe I had the right stick all the way forward when I first got the message because I was taking video down a straight path, but the quad started to drift off the straight ahead track. Then maybe I let up of the stick and it drifted down wind. Then I flew against the wind and worked my way to land more or less where I took off from. I am not a particularly good pilot and I actually think that, while something was definitely not right, GPS was still sort of helping me out.

    After GPS was lost, sometimes I had to have the right stick all the way forward to maintain XY position. Then with the stick forward the quad would move up wind and I'd let off, thinking the GPS was back and all was back to normal (but maybe it was just the wind gusts died down for a second?). Then the quad would drift again and I'd have to calibrate how much stick to give it to try to maintain position, while bringing it down to land.

    I investigated the telemetry files and I still don't know why/what happened. Even though I was supposedly flying without GPS the whole flight track was recorded in telemetry. When I converted to kml and opened in Google Earth it seems to me that it exactly matches the flight path.

    I'm uploading the telemetry logs in case someone can help me find an explanation. The one thing that I noticed which seemed not right is that the voltage reading recorded in the Telemetry file (Quad data) increased between the time when the GPS problems started and when I landed. I wonder if this could be the problem or give an indication of the problem? There were no error flags in the entire log, which I find strange.

    Thanks in advance for any help.
     

    Attached Files:

  2. Keith L Gordon

    Keith L Gordon New Member

    Jan 30, 2018
    2
    0
    1
    Male
    As I was reading your story, it sounded like you were fighting some serious wind gusts, upon reading your telemetry reports, I see you are flying off the south coast of Edinburgh of the Seven Seas in the mid Atlantic, so you would have been hard pressed to find a place to land on dry ground, as it has you 800 miles west of the tip of South Africa, If this isn't where you were flying, I would highly recommend finding true north on a compass and calibrate your GPS with a PC...I have a chroma too, and I don't know much, I just saw this and thought i'd put my 2 cents in, because this is the only place we have for support, since blade and yuneec have turned their backs on Chroma owners...I've been looking for a cgo2+ power board for a week now, blade gave me the contact info for yuneec, who in turn gave me the contact info for blade, and marked the problem solved.
    Anyway, I hope you already had a solution, or alternatively that I helped.
    Happy Cloud Surfing!
     
  3. E_Bro

    E_Bro New Member

    Aug 1, 2016
    19
    3
    3
    See this from original post.

    You processed the telemetry and found that the track fell out in the ocean? When I converted it and loaded it up in Google Earth it looked to be in the right place and to perfectly match (or pretty dang close) the actual flight path.

    I'm getting used to having all kinds of issues while flying my Chroma. Sometimes, after just a few minutes, I'll get low voltage warnings for a battery that I charged to capacity before going out. When I land, the voltage goes back up right away. I don't have a device to measure internal resistance. I wish I knew how to check this with a multimeter.

    Another problem is the gimbal sometimes goes off kilter in the middle of a flight. It starts out close enough to level but mid-flight goes awry.

    Another problem is frequent drop out of the video feed on the ST-10+. Occasional, but infrequent, drop of connection between transmitter-copter RC.

    Another thing that's happening a lot is the flashing white LEDs in mid-flight and warnings in the telemetry logs saying Compass Calibration Warning. I half wonder if sometimes the problem is to do with the GPS of the controller, because in walking around on sites I am sometimes near lots of metal.

    Good luck in your hunt for a cgo2+ power board.
     
Loading...

Share This Page