Typhoon H from hell!

Discussion in 'Help' started by Cocabomo, Dec 31, 2016.

  1. Coc

    Cocabomo New Member

    Joined:
    Dec 31, 2016
    Messages:
    2
    Likes Received:
    0
    Hello everyone and happy holidays-
    I have a brand new typhoon H drone and unfortunately I'm having nothing but problem after problem! Any help would be GREATLY appreciated otherwise I am going to return it.

    Here is the story- the drone arrived 2 weeks ago, once I got it I started the registration process and reading the manual. Then I turned it on to better learn the controller and how to move the camera. During that time no matter what I did I couldn't get the camera to display on the controller! After 4 days of trying it decided to work! Then we finally had a good weather day for me to take it outside and fly it. I turned on the controller then powered on the drone and just like before it wouldn't connect, so I gave up. I then looked online and saw firmware updates are avaible for both the controller and the drone so I updated both. Then next day I went outside to fly it, I powered on the controller then the drone and instantly they connected! Then I clicked on calibrate then compass, and nothing happened! I restarted everything and tried again and the same thing! Nothing happens at all, it's as if I never clicked on it. After trying for an hour I gave up! I then went home and re-installed all the updates. The next day I went outside and turned it on. Instantly after connecting I get a warning screen saying "WARNING obs avoidance failed" I restarted several times with no luck. So I went home and reinstalled all updates AGAIN! The next day I went outside to try again. Everything connected but the calibration still does not work no matter what I do! But I wanted to see if it will even fly so I hit then "start engine" and nothing happened, so I tried holding it down and pressing it rapidly and nothing. So I put the controller down and walk toward it and out of no where it turns on!!!! So I grab the controller and hit the throttle up button and nothing happenes! Then a min later it moves up in the air, so I start to fly it moving side to side and up and down. 2 minutes later I bring it down to land. 2 feet off the ground it stops responding! So I hit the "stop engine" and NOTHING at all happens. It then starts reving it's motors! So I run over and grab the landing gears. The second I grab the landing gear it goes into full throttle! I'm holding it back to stop it from flying away but the motors start spinning even faster! At this point I'm frantically pushing the stop engine button and the throttle down! But nothing will stop it from going full throttle! I then carefully slip my hands in and hold down the power button on the drone, and nothing happens! Then I frantically rip the battery out of the drone!

    What is happening? It's problem after problem after problem! I can't even fly this! NOTHING ON IT WORKS!!!!! Please help me!!!!
     
  2. Coc

    Cocabomo New Member

    Joined:
    Dec 31, 2016
    Messages:
    2
    Likes Received:
    0
    PLEASE HELP! Anyone?!!!!!!
     
  3. Jagerbomb52

    Jagerbomb52 Moderator Staff Member

    Joined:
    Jun 3, 2015
    Messages:
    4,755
    Likes Received:
    1,756
    Location:
    Canada
    Wish I could tell you something that would fix it for you but I would say either return the demand from hell for a refund or call Yuneec and send it in to be fixed.
     
  4. RT-Albany

    RT-Albany New Member

    Joined:
    May 26, 2016
    Messages:
    14
    Likes Received:
    4
    Did you do a rebind after firmware update?
     
    Hedobum likes this.
  5. Hed

    Hedobum New Member

    Joined:
    Nov 13, 2016
    Messages:
    9
    Likes Received:
    0
    Yes. You do need to rebind both the UAV and the Camera to the st16 after any update.
     
  6. Dennisdrone

    Dennisdrone Active Member

    Joined:
    Nov 8, 2016
    Messages:
    195
    Likes Received:
    43
    I also had a spooky typhoon H, bad connection and it reacted weird. Contacted Yuneec and received a video with a solution. It worked for me. Flightcontroller 1.28 had to be flashed. After that i upgraded to the latest version and i'm flying flawless until now... Don't forget to bind and callibrate



    Greetz from holland
     
  7. Joe

    Joe Ogiba New Member

    Joined:
    Feb 4, 2016
    Messages:
    8
    Likes Received:
    3
    It seems to me the Typhoon H has more problems than the Q500 4K that I have that has had zero problems so far for me since I got it a year ago.
     
  8. ern

    erno lutz New Member

    Joined:
    Nov 20, 2016
    Messages:
    14
    Likes Received:
    4
    I agree, re-install both camera and ST16 software and watch the video by Dennis. You must re-bind during update.
     
  9. farouk2003

    farouk2003 New Member

    Joined:
    Dec 20, 2016
    Messages:
    12
    Likes Received:
    1
    There's is one secret I've fund out and this could solve your problem.

    1: clear typhoon H data from ST16

    2: install v1.29 by using the GUI on your PC

    3: bind the H and the camera

    4: calibrate accelerometer

    5: calibrate the ST16 after every new installed firmware. very important !!

    6: calibrate the compass at the field
    Making sure there's no metals around you



    I hope this would help. Enjoy your flight
     
    Last edited: Feb 21, 2017
Loading...

Share This Page

Loading...