Q500 4K will not enter follow me/watch me mode, Help Please

Discussion in 'Q500/Q500+/Q500 4K/Typhoon G' started by Mcwethy, Jan 6, 2017.

  1. Mcw

    Mcwethy New Member

    Joined:
    Jan 6, 2017
    Messages:
    2
    Likes Received:
    0
    hello im new here to the forum, and new to drones i recieved a Q500 4K for christmas and i have been slowly getting the hang of things with it.

    my problems so far are that i can not get the drone to follow me or watch me

    i have updated the drone the gimbal and the ground station,
    i have selected the CGO3-pro camera mode to get all the other settings for picture/video,

    is there any reason why is wouldnt enter the modes, the Eye icon is there but its just greyed out, even in smart mode, and usually the controller shows somewhere between 10-15 Satellites for both teh drone and the remote,
    please help its very frustrating!
     
  2. Jagerbomb52

    Jagerbomb52 Moderator Staff Member

    Joined:
    Jun 3, 2015
    Messages:
    4,705
    Likes Received:
    1,734
    Location:
    Canada
    Sounds like you have enough satellites. The controller needs at least 7-9 before the Eye icon will activate. The Q500 will always be the first one to populate satellites and most likely have a number around 10-13. So if all those are satisfied I would try to reinstall the firmware on the ST10+ and also try this. You might have to rebind the quad to get this to work.


    Turn Everything Off Bird and TX

    Turn on the ST10+ but not the bird

    After it initializes select Model. Select it at the bottom right of screen.

    Touch and Hold the model. Menu appears. Touch & DELETE.

    Now turn off ST10+

    Turn on the Bird. After it is on, Tilt forward from the back end 45 degrees two times to enter Bind Mode. Back light will start flashing Orange.

    Turn on ST10+ Select Flight Settings,at this time it will ask you to go to model select and create a new model. Once you have giving it a name click save and then Select Bind. Bind the Model and Bind the Camera

    Tap Return Button at bottom of ST10+ a few times to get back to main screen. You should now see the camera come up on display.
     
  3. Mcw

    Mcwethy New Member

    Joined:
    Jan 6, 2017
    Messages:
    2
    Likes Received:
    0
    Ohhhh man that works perfectly! Thank you so much! All I ended up having to do was re bind it!
     
  4. Jagerbomb52

    Jagerbomb52 Moderator Staff Member

    Joined:
    Jun 3, 2015
    Messages:
    4,705
    Likes Received:
    1,734
    Location:
    Canada
    Great, easy fix.
    Now get out there and have fun :)
     
Loading...

Share This Page

Loading...